Why can't I access CUTX through my Android phone?

Due to some recent security upgrades Members with Android phones must be on Android OS 4.5 or higher. If you have any questions please contact us.